Meteor 1.4 Beta 发布了

最重大的变化是 Node.js 版本从 0.10 升级到 4.4.5,还有 MongoDB 版本升级到 3.2

Node.js 4

目前是先升级到 4,然后确保以后升级 Node 更容易。这个带来的其他一个问题就是 Atmosphere 包管理也需要改变,以后需要 Meteor 用户在自己的开发和生产环境编译使用到的包,但是核心的包会直接下载二进制包,所以不用编译。

一旦解决了 Node 4 的问题,Node 6 也不远了。

MongoDB 3.2

终于升级了 Mongo。但是因为驱动改变,开发环境的数据库需要 reset。

更宽松的核心包版本

以前 Meteor 的 core package 升级只能伴随 Meteor 版本的升级,现在可以单独升级核心包版本了。这也是向 NPM 包管理方式靠拢的一步。

其他

Meteor 1.4 可以在 ARM v7 以上环境直接运行了。意味着以后可以在树莓派上运行 Meteor 服务。